1
Ниже на языке программирования Pascal записан алгоритм. var x, L, M: integer; begin readln(x); L := 1; M := 0; while x > 0 do begin M := M + 1; if x mod 2 <> 0 then L := L * (x mod 8); x := x div 8 end; writeln(L); writeln(M) end. Получив на вход натуральное десятичное число x этот алгоритм печатает два числа: L и M Укажите наибольшее число x при вводе которого алгоритм печатает сначала 35 а потом 3
Варианты ответов и условие задания
Проверка ответа и решение
Ответ скрыт — доступен в Telegram-боте
Получить ответ в боте Как проверить правильный ответ на задание?
Для моментальной проверки ответов на домашние задания, контрольные и тесты МЭШ, ЦДЗ, РЭШ и Skysmart используйте бота KING.ANSWERS. Помогает быстро сверить решения и разобрать ошибки в тестовых материалах.